Back to overview
Resolved
Apartment listings not appearing on the website
Jul 27, 2026 at 12:14pm UTC
Affected services
Website
Resolved
Jul 27, 2026 at 1:41pm UTC
We've fixed the issue that prevented some apartments from showing on the website.
Affected services
Created
Jul 27, 2026 at 12:14pm UTC
The issue preventing listings from appearing on the website has been resolved, and all apartments are now displaying as expected.
Affected services