Back to overview
Resolved
Some apartments aren’t showing
Jul 11, 2026 at 2:20pm UTC
Affected services
Website
Resolved
Jul 11, 2026 at 6:05pm UTC
We've fixed the issue that prevented older apartments from showing on the website.
Affected services
Created
Jul 11, 2026 at 2:20pm UTC
Some apartments aren’t showing on the website when you scroll down. We’re working on a fix.
Affected services